Comprar agora Comprar agora Comprar agora Comprar agora Comprar agora Download_on_the_App_Store_Badge_RU_135x40 Download_on_the_App_Store_JP_135x40 Download_on_the_App_Store_Badge_PTBR_135x40

Out now on iPad®

Device Requirements

ROME: Total War requires a first generation iPad Air or newer, an iPad mini 2 or newer, or any iPad Pro, and just under 4GB of free space to install. You will need iOS 10.2.0 or newer.

Supported iPads

Asset 6
  • iPad Pro
    12.9-inch
    (2nd generation)
  • iPad Pro
    12.9-inch
  • iPad Pro
    10.5-inch
  • iPad
    (2017)
  • iPad Pro
    9.7-inch
  • iPad Air 2
  • iPad Air
  • iPad Mini 4
  • iPad Mini 3
  • iPad Mini 2